<!doctype html>
<html lang=en>
  <head>
    <meta charset=utf-8>
<title>You should use ReadonlyArray in your React state | Tiger Oakes</title>
<meta name=description content="Preventing a common React bug.">
<link rel=icon type=image/svg+xml href=/favicon.svg sizes=any>
<link rel=icon type=image/png href=/favicon_x16.png sizes=16x16>
<link rel=icon type=image/png href=/favicon_x48.png sizes=48x48>
<link rel=icon type=image/png href=/favicon_x512.png sizes=512x512>
<link rel=canonical href=https://tigeroakes.com/posts/readonly-by-default/ >
<link rel=manifest href=/site.webmanifest>
<meta name=viewport content="width=device-width,initial-scale=1">
<meta name=theme-color content=#e67237>
<meta name=monetization content=$ilp.uphold.com/p2WKq3nJHA8w>
<script src=https://caterpilla.tigeroakes.com/script.js data-site=CSXBFPSZ defer></script>
<link rel=preload href=/font/lato/LatoLatin-Regular.woff2 as=font type=font/woff2 crossorigin>
<link rel=preload href=/font/cascadia-code/CascadiaMono-Variable.woff2 as=font type=font/woff2 crossorigin>


<script type=application/ld+json>{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Tiger Oakes","item":"https://tigeroakes.com/"},{"@type":"ListItem","position":2,"name":"Blog","item":"https://tigeroakes.com/posts"},{"@type":"ListItem","position":3,"name":"You should use ReadonlyArray in your React state"}]}</script>


    <meta name=og:title content="You should use ReadonlyArray in your React state">
<meta name=og:type content=website>
<meta name=og:url content=https://tigeroakes.com/posts/readonly-by-default/ >
<meta name=og:description content="Preventing a common React bug.">
<meta name=og:site_name content="Tiger Oakes">
<meta name=og:image content=https://tigeroakes.com/assets/images/readonly-by-default-banner.hYt6MTnpNd.png>


<meta name=twitter:card content=summary_large_image>
<meta name=twitter:site content=@Not_Woods>
<meta name=twitter:title content="You should use ReadonlyArray in your React state">
<meta name=twitter:description content="Preventing a common React bug.">
<meta name=twitter:image content=https://tigeroakes.com/assets/images/readonly-by-default-banner.hYt6MTnpNd.png>


    <script type=application/ld+json>{"@context":"https://schema.org","@type":"BlogPosting","mainEntityOfPage":"https://tigeroakes.com/posts/readonly-by-default/","headline":"You should use ReadonlyArray in your React state","image":["https://tigeroakes.com/assets/images/readonly-by-default-banner.hYt6MTnpNd.png"],"datePublished":"2022-07-25T00:00:00","author":{"@type":"Person","name":"Tiger Oakes","url":"https://tigeroakes.com/"}}</script>

  <link rel=stylesheet href=/assets/c616a036.1d9f5dac.css>
<link rel=stylesheet href=/assets/46f1da85.3723acfc.css>
<link rel=stylesheet href=/assets/262f62b5.58638717.css><script type=module>function s(){const n=document.getElementById("table-of-contents");if(!n)return;let r;function o(t){r&&r.removeAttribute("aria-current");const e=n.querySelector(`a[href="#${t}"]`);e?(e.setAttribute("aria-current","location"),r=e):r=void 0}const i=new IntersectionObserver(t=>{for(const e of t)if(e.isIntersecting){o(e.target.id);break}},{rootMargin:"0% 0% -66%",threshold:1});document.querySelectorAll(".prose :is(h1,h2,h3,h4,h5,h6)").forEach(t=>i.observe(t))}s();
</script></head>

  <body class="bg-slate-800 text-slate-200">
    <header class="flex flex-wrap items-stretch max-w-site mx-auto justify-between p-4 gap-y-4 astro-U4RJAH4F">
	<h1 class="grow pr-2 astro-H2BZ5ZCG">
  <a class="block astro-H2BZ5ZCG" href=/ >
    <svg class="logo astro-H2BZ5ZCG" width=160 height=28 viewBox="0 2 80 14">
      <title>Tiger Oakes</title>
      <rect class="background astro-H2BZ5ZCG" width=12 height=12 x=2 y=2 fill=#e67237></rect>
      <g fill=none stroke=#032030 class=astro-H2BZ5ZCG>
        
        <circle class="eye astro-H2BZ5ZCG" cx=5 cy=6 r=1.5></circle>
        <circle class="eye astro-H2BZ5ZCG" cx=11 cy=6 r=1.5></circle>
        <path class="eye-closed astro-H2BZ5ZCG" d="M3 6h4"></path>
        <path class="eye-closed astro-H2BZ5ZCG" d="M9 6h4"></path>
        <path d=M4.5,7.5v3.5l2.5,1.5m4.5,-4.9v3.4l-2.5,1.5 class=astro-H2BZ5ZCG></path>
      </g>
      <path fill=#032030 d=M8,10.6l1.5,-1.6h-3l1.5,1.6Z class=astro-H2BZ5ZCG></path>
      <clipPath id=i class=astro-H2BZ5ZCG>
        <path d="M29 8v6h-3V8h3zm0-1h-3V5h3v2z" class=astro-H2BZ5ZCG></path>
      </clipPath>
      <g class="text astro-H2BZ5ZCG" fill=none stroke=currentColor opacity=0.5 stroke-miterlimit=1.5>
        <path style=animation-delay:.3s d="M23.5 13V7l-.5-.5h-3l-.5-.5V5l.5-.5h7" class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.6s d="M28 13l-.5-.5V6" clip-path=url(#i) class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.9s d=M32.5,12.5h-2.5l-.5,-.5v-4l.5,-.5h3l.5,.5v7l-.5,.5h-3l-.5,-.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.2s d=M36.5,10h2l.5,-.5v-1.5l-.5,-.5h-2.5l-.5,.5v4l.5,.5h2.5l.5,-.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.5s d=M40.5,7.5l.5,.5v4l.5,.5h.5l.5,-.5v-4l.5,-.5h1.5l.5,.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.3s d=M55.5,12.5h-4.5l-.5,-.5v-7l.5,-.5h4l.5,.5v6 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.6s d=M57.5,8l.5,-.5h3l.5,.5v4l-.5,.5h-3l-.5,-.5v-2l.5,-.5h2 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.9s d=M63,13l.5,-.5v-8.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.2s d=M66.5,6v2l-.5,.5h-.5l-.5,.5v1l.5,.5h2l.5,.5v2 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.5s d=M71,10h2l.5,-.5v-1.5l-.5,-.5h-2.5l-.5,.5v4l.5,.5h2.5l.5,-.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.8s d=M75.5,12l.5,.5h3l.5,-.5v-1.5l-.5,-.5h-3l-.5,-.5v-1.5l.5,-.5h3l.5,.5 class=astro-H2BZ5ZCG></path>
      </g>
      <g class="text astro-H2BZ5ZCG" fill=none stroke=currentColor stroke-miterlimit=1.5>
        <path style=animation-delay:.5s d="M23.5 13V7l-.5-.5h-3l-.5-.5V5l.5-.5h7" class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.8s d="M28 13l-.5-.5V6" clip-path=url(#i) class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.1s d=M32.5,12.5h-2.5l-.5,-.5v-4l.5,-.5h3l.5,.5v7l-.5,.5h-3l-.5,-.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.4s d=M36.5,10h2l.5,-.5v-1.5l-.5,-.5h-2.5l-.5,.5v4l.5,.5h2.5l.5,-.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.7s d=M40.5,7.5l.5,.5v4l.5,.5h.5l.5,-.5v-4l.5,-.5h1.5l.5,.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.5s d=M55.5,12.5h-4.5l-.5,-.5v-7l.5,-.5h4l.5,.5v6 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:.8s d=M57.5,8l.5,-.5h3l.5,.5v4l-.5,.5h-3l-.5,-.5v-2l.5,-.5h2 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.1s d=M63,13l.5,-.5v-8.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.4s d=M66.5,6v2l-.5,.5h-.5l-.5,.5v1l.5,.5h2l.5,.5v2 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:1.7s d=M71,10h2l.5,-.5v-1.5l-.5,-.5h-2.5l-.5,.5v4l.5,.5h2.5l.5,-.5 class=astro-H2BZ5ZCG></path>
        <path style=animation-delay:2s d=M75.5,12l.5,.5h3l.5,-.5v-1.5l-.5,-.5h-3l-.5,-.5v-1.5l.5,-.5h3l.5,.5 class=astro-H2BZ5ZCG></path>
      </g>
    </svg>
  </a>
</h1>


	

	<nav class="flex flex-wrap items-stretch mx-auto gap-x-2 gap-y-6">
		<a class="px-2 relative accent-block--bottom" href=/posts/ aria-current=page>
				Blog
			</a><a class="px-2 relative accent-block--bottom" href=/projects/ >
				Projects
			</a><a class="px-2 relative accent-block--bottom" href=/talks/ >
				Talks
			</a><a class="px-2 relative accent-block--bottom" href=/resume/ >
				Resume
			</a>
	</nav>
</header>

<article class="grid bg-slate-200 text-slate-800 dark:bg-zinc-800 dark:text-slate-200 astro-U4RJAH4F">
  
    <header class="text-slate-200 bg-center bg-cover bg-no-repeat shadow-md p-4 grid-area-header bg-slate-800 pt-8 md:pt-4" style=--accent:#3178c6>
      <div class="max-w-site mx-auto p-4 w-full">
        <time class="inline-block text-sm opacity-80 mb-2" datetime=2022-07-25>
  Posted on
  2022, July
  25
</time><h2 class="text-3xl font-normal mb-1">
  <span class="relative accent-block--left accent-block--still">
    You should use ReadonlyArray in your React state
  </span>
</h2><p class="text-lg mb-2">
  Preventing a common React bug.
<ul class="leading-normal opacity-80 mt-auto text-sm">
  
  <li class="pipe-item inline"><a class=hover:underline href=/tags/web/ >Web</a><li class="pipe-item inline"><a class=hover:underline href=/tags/react/ >React</a></li>
  
</ul>
        <div class="buttons flex flex-wrap gap-2 mt-3 text-lg justify-center astro-KGOJNJEQ">
  
</div>


     </div>
    </header>
  
  <nav class="table-of-contents min-w-44 lg:sticky lg:max-h-screen top-0 lg:justify-self-end self-start flex flex-col pl-1 pr-4 mt-8 lg:mt-12 astro-QMH2F3P4">
  <h2 class="border-b py-1 uppercase ml-3 mb-2 astro-QMH2F3P4">
    On this page
    <a class="hidden lg:inline-block astro-QMH2F3P4" href=# title="Back to top">↥</a>
  </h2>
  <div class="grow overflow-y-auto pb-4 astro-QMH2F3P4">
    <ul id=table-of-contents class=ml-3>
  <li class=leading-5>
      <a class="block mb-1 relative accent-block--left" href=#whats-wrong-with-mutable-types>
        What’s wrong with mutable types?
      </a>
      
    <li class=leading-5>
      <a class="block mb-1 relative accent-block--left" href=#use-typescript-to-avoid-mutations>
        Use TypeScript to avoid mutations
      </a>
      
    <li class=leading-5>
      <a class="block mb-1 relative accent-block--left" href=#local-mutations-are-still-ok>
        Local mutations are still OK
      </a>
      
    <li class=leading-5>
      <a class="block mb-1 relative accent-block--left" href=#read-only-collections-and-objects>
        Read-only collections and objects
      </a>
      
    <li class=leading-5>
      <a class="block mb-1 relative accent-block--left" href=#other-uses-for-read-only-types>
        Other uses for read-only types
      </a>
      
    </li>
</ul>
  </div>
</nav>




  <div class="prose prose-lg dark:prose-invert max-w-site px-4 py-6 astro-U4RJAH4F">
    <p>If you’ve ever written any React code, you’ve probably used arrays to represent state: an array of todo items, articles fetched from the server, and more. But sometimes React doesn’t update after you change that state. Usually, that’s because you mutated an array instead of copying it - a mistake easily prevented by using read-only types like <code>ReadonlyArray</code>. Here’s why you should start switching to read-only!<h2 id=whats-wrong-with-mutable-types>What’s wrong with mutable types?</h2><p><a href=https://reactjs.org/docs/hooks-state.html><code>useState</code></a> only triggers a render when the old and new state values are not equal (<code>!==</code>). When you work with primitive types like strings and numbers, that’s not a problem. Primitives are compared by value (<code>'a' === 'a'</code>), and you can only mutate the state by calling the setter returned from <code>useState</code>, so its clear when state changes will trigger a render.<p>But arrays and other objects are more complicated. Objects are compared by identity instead of value (<code>['a'] !== ['a']</code>). And if you change the contents of an array by mutating it with <code>.push</code>, that will not change its identity.<pre class=astro-code style=background-color:#1e1e1e;overflow-x:auto><code><span class=line><span style=color:#6a9955>// Don&#39;t do:</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> [</span><span style=color:#4fc1ff>array</span><span style=color:#d4d4d4>, </span><span style=color:#4fc1ff>setArray</span><span style=color:#d4d4d4>] = </span><span style=color:#9cdcfe>React</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>useState</span><span style=color:#d4d4d4>&lt;</span><span style=color:#4ec9b0>string</span><span style=color:#d4d4d4>[]&gt;([</span><span style=color:#ce9178>&#39;a&#39;</span><span style=color:#d4d4d4>]);</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>onClick</span><span style=color:#d4d4d4> = () </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>setArray</span><span style=color:#d4d4d4>(</span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4> </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>push</span><span style=color:#d4d4d4>(</span><span style=color:#ce9178>&#39;b&#39;</span><span style=color:#d4d4d4>); </span><span style=color:#6a9955>// mutates the same array</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#c586c0>return</span><span style=color:#d4d4d4> </span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>  });</span></span>
<span class=line><span style=color:#d4d4d4>}</span></span></code></pre><p>It won’t trigger a render if you just push to the the array. It also won’t trigger a render if you mutate that array and then set it as the new state, since the two states refer to the same object.<p>The correct thing to do is always make a new copy of the collection when changing it, often by using the <a href=https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Operators/Spread_syntax>spread operator</a>.<pre class=astro-code style=background-color:#1e1e1e;overflow-x:auto><code><span class=line><span style=color:#6a9955>// Do:</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> [</span><span style=color:#4fc1ff>array</span><span style=color:#d4d4d4>, </span><span style=color:#4fc1ff>setArray</span><span style=color:#d4d4d4>] = </span><span style=color:#9cdcfe>React</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>useState</span><span style=color:#d4d4d4>&lt;</span><span style=color:#4ec9b0>string</span><span style=color:#d4d4d4>[]&gt;([</span><span style=color:#ce9178>&#39;a&#39;</span><span style=color:#d4d4d4>]);</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>onClick</span><span style=color:#d4d4d4> = () </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>setArray</span><span style=color:#d4d4d4>(</span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4> </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> [...</span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>, </span><span style=color:#ce9178>&#39;b&#39;</span><span style=color:#d4d4d4>]); </span><span style=color:#6a9955>// copies into a new array</span></span>
<span class=line><span style=color:#d4d4d4>}</span></span></code></pre><p>Brand new arrays will always have a different identity than existing arrays. Now React knows to rerender, because the new state doesn’t equal the old state.<h2 id=use-typescript-to-avoid-mutations>Use TypeScript to avoid mutations</h2><p>So now we know that we shouldn’t mutate arrays stored in React state…but how do we avoid it? You can choose to memorize every array function, and remember which ones mutate an array and which ones create a copy. Instead, let’s enforce the correct functions with TypeScript.<p>TypeScript offers the <code>ReadonlyArray&lt;T&gt;</code> type (which can also be written as <code>readonly T[]</code>), which represents an array with all the setters removed. That forces us to always make a copy, and let TypeScript quickly point it out anytime we forget with a type error.<pre class=astro-code style=background-color:#1e1e1e;overflow-x:auto><code><span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> [</span><span style=color:#4fc1ff>array</span><span style=color:#d4d4d4>, </span><span style=color:#4fc1ff>setArray</span><span style=color:#d4d4d4>] = </span><span style=color:#9cdcfe>React</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>useState</span><span style=color:#d4d4d4>&lt;</span><span style=color:#569cd6>readonly</span><span style=color:#d4d4d4> </span><span style=color:#4ec9b0>string</span><span style=color:#d4d4d4>[]&gt;([</span><span style=color:#ce9178>&#39;a&#39;</span><span style=color:#d4d4d4>]);</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>onClick</span><span style=color:#d4d4d4> = () </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>setArray</span><span style=color:#d4d4d4>(</span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4> </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#6a9955>// Type error: Property &#39;push&#39; does not exist on type &#39;readonly string[]&#39;.</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>push</span><span style=color:#d4d4d4>(</span><span style=color:#ce9178>&#39;b&#39;</span><span style=color:#d4d4d4>);</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#c586c0>return</span><span style=color:#d4d4d4> </span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>  });</span></span>
<span class=line><span style=color:#d4d4d4>}</span></span></code></pre><p>This makes it much clearer to future editors of your codebase. It makes it clear that there is only one way to update the array, and that there are no mutations in the existing code.<p>Since <code>ReadonlyArray</code> has all the same getters as an array, you can always pass in a regular array wherever a readonly array is expected.<pre class=astro-code style=background-color:#1e1e1e;overflow-x:auto><code><span class=line><span style=color:#569cd6>function</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>List</span><span style=color:#d4d4d4>(</span><span style=color:#9cdcfe>props</span><span style=color:#d4d4d4>: { </span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>: </span><span style=color:#569cd6>readonly</span><span style=color:#d4d4d4> </span><span style=color:#4ec9b0>string</span><span style=color:#d4d4d4>[] }) {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#c586c0>return</span><span style=color:#d4d4d4> </span><span style=color:grey>&lt;</span><span style=color:#569cd6>ul</span><span style=color:grey>&gt;</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#569cd6>{</span><span style=color:#9cdcfe>props</span><span style=color:#d4d4d4>.</span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>map</span><span style=color:#d4d4d4>(</span><span style=color:#9cdcfe>item</span><span style=color:#d4d4d4> </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> </span><span style=color:grey>&lt;</span><span style=color:#569cd6>li</span><span style=color:grey>&gt;</span><span style=color:#569cd6>{</span><span style=color:#9cdcfe>item</span><span style=color:#569cd6>}</span><span style=color:grey>&lt;/</span><span style=color:#569cd6>li</span><span style=color:grey>&gt;</span><span style=color:#d4d4d4>)</span><span style=color:#569cd6>}</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:grey>&lt;/</span><span style=color:#569cd6>ul</span><span style=color:grey>&gt;</span></span>
<span class=line><span style=color:#d4d4d4>}</span></span>
<span class=line></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#4fc1ff>data</span><span style=color:#d4d4d4>: </span><span style=color:#4ec9b0>string</span><span style=color:#d4d4d4>[] = [</span><span style=color:#ce9178>&#39;hello&#39;</span><span style=color:#d4d4d4>, </span><span style=color:#ce9178>&#39;world&#39;</span><span style=color:#d4d4d4>];</span></span>
<span class=line><span style=color:grey>&lt;</span><span style=color:#4ec9b0>List</span><span style=color:#d4d4d4> </span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>=</span><span style=color:#569cd6>{</span><span style=color:#9cdcfe>data</span><span style=color:#569cd6>}</span><span style=color:#d4d4d4> </span><span style=color:grey>/&gt;</span></span></code></pre><h2 id=local-mutations-are-still-ok>Local mutations are still OK</h2><p>While you should use readonly types for your state, it’s still OK to mutate an array when you’re constructing the next state value. <code>array.slice()</code> gives you a fresh copy of an array to mutate however you need.<pre class=astro-code style=background-color:#1e1e1e;overflow-x:auto><code><span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> [</span><span style=color:#4fc1ff>array</span><span style=color:#d4d4d4>, </span><span style=color:#4fc1ff>setArray</span><span style=color:#d4d4d4>] = </span><span style=color:#9cdcfe>React</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>useState</span><span style=color:#d4d4d4>&lt;</span><span style=color:#569cd6>readonly</span><span style=color:#d4d4d4> </span><span style=color:#4ec9b0>string</span><span style=color:#d4d4d4>[]&gt;([</span><span style=color:#ce9178>&#39;a&#39;</span><span style=color:#d4d4d4>, </span><span style=color:#ce9178>&#39;b&#39;</span><span style=color:#d4d4d4>, </span><span style=color:#ce9178>&#39;c&#39;</span><span style=color:#d4d4d4>]);</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>onClick</span><span style=color:#d4d4d4> = () </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>setArray</span><span style=color:#d4d4d4>(</span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4> </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#4fc1ff>copy</span><span style=color:#d4d4d4> = </span><span style=color:#9cdcfe>array</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>slice</span><span style=color:#d4d4d4>(); </span><span style=color:#6a9955>// returns string[], not readonly string[]</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>copy</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>splice</span><span style=color:#d4d4d4>(</span><span style=color:#b5cea8>1</span><span style=color:#d4d4d4>, </span><span style=color:#b5cea8>1</span><span style=color:#d4d4d4>);</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>copy</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>push</span><span style=color:#d4d4d4>(</span><span style=color:#ce9178>&#39;d&#39;</span><span style=color:#d4d4d4>);</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#6a9955>// no problems, because the new state `copy` !== the old state `array`</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#c586c0>return</span><span style=color:#d4d4d4> </span><span style=color:#9cdcfe>copy</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>  });</span></span>
<span class=line><span style=color:#d4d4d4>}</span></span></code></pre><h2 id=read-only-collections-and-objects>Read-only collections and objects</h2><p>There are also read-only variants of other collections, like <code>ReadonlyMap</code> and <code>ReadonlySet</code>. Just like <code>ReadonlyArray</code>, these types don’t include any functions that let you mutate the collection.<p>You can apply the same principles to objects, too. The <code>Readonly&lt;T&gt;</code> type lets you remove the setters from properties in an object type.<pre class=astro-code style=background-color:#1e1e1e;overflow-x:auto><code><span class=line><span style=color:#569cd6>interface</span><span style=color:#d4d4d4> </span><span style=color:#4ec9b0>Bike</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#9cdcfe>speed</span><span style=color:#d4d4d4>: </span><span style=color:#4ec9b0>number</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>}</span></span>
<span class=line></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> [</span><span style=color:#4fc1ff>bike</span><span style=color:#d4d4d4>, </span><span style=color:#4fc1ff>setBike</span><span style=color:#d4d4d4>] = </span><span style=color:#9cdcfe>React</span><span style=color:#d4d4d4>.</span><span style=color:#9cdcfe>useState</span><span style=color:#d4d4d4> &lt; </span><span style=color:#9cdcfe>Readonly</span><span style=color:#d4d4d4> &lt; </span><span style=color:#9cdcfe>Bike</span><span style=color:#d4d4d4> &gt;&gt; { </span><span style=color:#9cdcfe>speed:</span><span style=color:#d4d4d4> </span><span style=color:#b5cea8>0</span><span style=color:#d4d4d4> };</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>onPedal</span><span style=color:#d4d4d4> = () </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>setBike</span><span style=color:#d4d4d4>((</span><span style=color:#9cdcfe>bike</span><span style=color:#d4d4d4>) </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#6a9955>// Type error: Cannot assign to &#39;speed&#39; because it is a read-only property.</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>bike</span><span style=color:#d4d4d4>.</span><span style=color:#9cdcfe>speed</span><span style=color:#d4d4d4> += </span><span style=color:#b5cea8>5</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#c586c0>return</span><span style=color:#d4d4d4> </span><span style=color:#9cdcfe>bike</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>  });</span></span>
<span class=line><span style=color:#d4d4d4>};</span></span></code></pre><p>You can also use the <a href=https://www.typescriptlang.org/docs/handbook/utility-types.html><code>Pick</code></a> helper to avoid any functions that mutate a class instance.<pre class=astro-code style=background-color:#1e1e1e;overflow-x:auto><code><span class=line><span style=color:#569cd6>class</span><span style=color:#d4d4d4> </span><span style=color:#4ec9b0>Car</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#9cdcfe>speed</span><span style=color:#d4d4d4> = </span><span style=color:#b5cea8>0</span><span style=color:#d4d4d4>;</span></span>
<span class=line></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>copy</span><span style=color:#d4d4d4>(</span><span style=color:#9cdcfe>speed</span><span style=color:#d4d4d4>: </span><span style=color:#4ec9b0>number</span><span style=color:#d4d4d4>) {</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#4fc1ff>newCar</span><span style=color:#d4d4d4> = </span><span style=color:#569cd6>new</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>Car</span><span style=color:#d4d4d4>();</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>newCar</span><span style=color:#d4d4d4>.</span><span style=color:#9cdcfe>speed</span><span style=color:#d4d4d4> = </span><span style=color:#9cdcfe>speed</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#c586c0>return</span><span style=color:#d4d4d4> </span><span style=color:#9cdcfe>newCar</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>  }</span></span>
<span class=line></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>mutate</span><span style=color:#d4d4d4>() {</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>speed</span><span style=color:#d4d4d4> += </span><span style=color:#b5cea8>10</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>  }</span></span>
<span class=line><span style=color:#d4d4d4>}</span></span>
<span class=line></span>
<span class=line><span style=color:#569cd6>type</span><span style=color:#d4d4d4> </span><span style=color:#4ec9b0>ReadonlyCar</span><span style=color:#d4d4d4> = </span><span style=color:#4ec9b0>Readonly</span><span style=color:#d4d4d4>&lt;</span><span style=color:#4ec9b0>Pick</span><span style=color:#d4d4d4>&lt;</span><span style=color:#4ec9b0>Car</span><span style=color:#d4d4d4>, </span><span style=color:#ce9178>&#39;speed&#39;</span><span style=color:#d4d4d4> | </span><span style=color:#ce9178>&#39;copy&#39;</span><span style=color:#d4d4d4>&gt;&gt;;</span></span>
<span class=line></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> [</span><span style=color:#4fc1ff>car</span><span style=color:#d4d4d4>, </span><span style=color:#4fc1ff>setCar</span><span style=color:#d4d4d4>] = </span><span style=color:#9cdcfe>React</span><span style=color:#d4d4d4>.</span><span style=color:#9cdcfe>useState</span><span style=color:#d4d4d4> &lt; </span><span style=color:#9cdcfe>ReadonlyCar</span><span style=color:#d4d4d4> &gt; </span><span style=color:#569cd6>new</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>Car</span><span style=color:#d4d4d4>();</span></span>
<span class=line><span style=color:#569cd6>const</span><span style=color:#d4d4d4> </span><span style=color:#dcdcaa>onPedal</span><span style=color:#d4d4d4> = () </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>  </span><span style=color:#dcdcaa>setCar</span><span style=color:#d4d4d4>((</span><span style=color:#9cdcfe>car</span><span style=color:#d4d4d4>) </span><span style=color:#569cd6>=&gt;</span><span style=color:#d4d4d4> {</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#6a9955>// Type error: Property &#39;mutate&#39; does not exist on type &#39;ReadonlyCar&#39;.</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#9cdcfe>car</span><span style=color:#d4d4d4>.</span><span style=color:#dcdcaa>mutate</span><span style=color:#d4d4d4>();</span></span>
<span class=line><span style=color:#d4d4d4>    </span><span style=color:#c586c0>return</span><span style=color:#d4d4d4> </span><span style=color:#9cdcfe>car</span><span style=color:#d4d4d4>;</span></span>
<span class=line><span style=color:#d4d4d4>  });</span></span>
<span class=line><span style=color:#d4d4d4>};</span></span></code></pre><h2 id=other-uses-for-read-only-types>Other uses for read-only types</h2><p>Read-only types are useful outside of React state and collections too. It’s useful for props and hooks to use and return read-only types to help enforce React’s update model across your app.<p>Outside of React, you might want to use read-only to indicate that you never mutate an array passed to a function. You might want to enforce that a class property or variable shouldn’t be changed.<p>Always think carefully about which parts of your data are mutable or not. Try using read-only by default instead of mutable collections!</p>
  </div>
  
    <footer class="article-nav flex justify-center py-8 astro-A6ESES3O">
  <a href=/posts/ class="button relative shadow text-center whitespace-nowrap px-6 py-2 bg-gray-100 dark:bg-slate-200 text-slate-800 text-2xl basis-64 astro-A6ESES3O">More blog posts</a>


</footer>


  
</article>

<aside class="max-w-site mx-auto px-4 py-8">
  <h2 class="text-2xl mx-4">Want to read more?</h2>
  <p class="text-lg m-4">
    On this site I try to write about interesting and weird projects, and my
    newsletter is no different! It includes <strong>early access</strong> to upcoming
    posts and access to special bonus content. No spam, unsubscribe at any time.
  </p>

  <form action=https://buttondown.email/api/emails/embed-subscribe/tiger method=post target=popupwindow onsubmit='window.open("https://buttondown.email/tiger","popupwindow")' class="subscribe flex flex-wrap mx-4 gap-4">
    <div class="flex flex-col flex-1">
      <input class="peer bg-transparent py-1" type=email name=email id=bd-email>
      <label class="order-first peer-focus:text-orange-500 motion-safe:transition-colors" for=bd-email>Email</label>
      <hr class="border-t-4 peer-focus:border-orange-500 peer-focus:translate-y-1.5 motion-safe:transition">
    </div>
    <input type=hidden value=1 name=embed>
    <button type=button type=submit class="button relative shadow text-center whitespace-nowrap px-6 py-2 text-xl bg-orange-500 text-slate-800 selection-invert ml-auto">
      Subscribe
    </button>


  </form>
</aside>
<footer class="flex flex-wrap m-8 justify-center astro-U4RJAH4F">
  <a class="leading-6 mx-2 my-4 relative accent-block--bottom" href=mailto:{email.link}>contact<wbr>@tigeroakes.com</a>
  <div class=flex>
    <a class="mx-2 my-4 relative accent-block--bottom" title=GitHub href=https://github.com/NotWoods>
        <img class=block width=24 height=24 alt=GitHub src=/contact/github.svg loading=lazy>
      </a><a class="mx-2 my-4 relative accent-block--bottom" title=LinkedIn href=https://linkedin.com/in/tigeroakes>
        <img class=block width=24 height=24 alt=LinkedIn src=/contact/linkedin.svg loading=lazy>
      </a><a class="mx-2 my-4 relative accent-block--bottom" title=Twitter href=https://twitter.com/Not_Woods>
        <img class=block width=24 height=24 alt=Twitter src=/contact/twitter.svg loading=lazy>
      </a>
  </div>
</footer>


  